[Solución] error: xml2-config not found. Please check your libxml2 installation.



Este error surgió al momento de hacer la configuración para instalar (Compilar) PHP-5.2 en Ubuntu, la verdad buscando en Internet encontré bastante documentación al respecto pero en el idioma Ingles, por lo que me doy cuenta que es un error mas común de lo que creía.

La solución es bastante simple, primero analicemos el problema:

configure: error: xml2-config not found. Please check your libxml2 installation.

Lo que nos dice es que no puede configurara xml2 y (en mi caso) cuando revise ya tenia instalado xml2 y libxml. Veamos la solución.

SOLUCION

Simplemente basta con instalar el paquete libxml2-devel o libxml2-dev es igual, cuando volvamos a seguir compilando PHP ya no generara este error y podremos instalarlo como debe ser 🙂

9 thoughts on “[Solución] error: xml2-config not found. Please check your libxml2 installation.

  1. hermano me has salvado la noche,estaba a punto de arrancarme los pelos jajajajaj gracias por tu aporte.

  2. Bueno amigo, gracias por tu ayuda. ya nada mas me queda hacer un “upgrade” a mi apache nativo (2.2.14) al actual (2.4.2.

  3. Ese error me aparecía al instalar phpfarm y querer instalar PHP 5.2.17; no me funcionó
    `sudo apt-get install libxml2-devel`
    pero si
    `sudo apt-get install libxml2-dev`

    Muchas muchas gracias

  4. Muchísimas gracias 🙂 ando iniciandome en phc (php compiler) saludos

  5. Esto merece un comentario
    que dios te cuide los ojos. Sigue leyendo
    Por que yo me los he dejado en todos los manuales de PHP

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *