Solucionar la vulnerabilidad GHOST



Ghost es una vulnerabilidad de la librería glibc que podría permitir la ejecución remota de código en sistemas basados en linux y afecta diferentes distribuciones, estas son algunas de las que probablemente se vean afectadas:

  • RHEL (Red Hat Enterprise Linux) versión 5.x, 6.x & 7.x
  • CentOS Linux versión 5.x, 6.x & 7.x
  • Ubuntu Linux versión 10.04, 12.04 LTS
  • Debian Linux versión 7.x
  • Linux Mint versión 13.0
  • Fedora Linux versión 19 o anteriores
  • SUSE Linux Enterprise 11 y anteriores (también OpenSuse Linux 11 o versiones anteriores).
  • SUSE Linux Enterprise Software Development Kit 11 SP3
  • SUSE Linux Enterprise Server 11 SP3 for VMware
  • SUSE Linux Enterprise Server 11 SP3
  • SUSE Linux Enterprise Server 11 SP2 LTSS
  • SUSE Linux Enterprise Server 11 SP1 LTSS
  • SUSE Linux Enterprise Server 10 SP4 LTSS
  • SUSE Linux Enterprise Desktop 11 SP3
  • Arch Linux glibc versión <= 2.18-1

ghost vulnerability

Este es un pequeño script en C para comprobar si el sistema es vulnerable o no, el archivo debe ser llamado ghosttest.c.

Luego se debe compilar y ejecutar con los siguientes comandos:

gcc ghosttest.c -o ghosttest
./ghosttest

Para solucionar la vulnerabilidad Ghost, el sistema debe ser actualizado, este es el procedimiento para las principales distribuciones:

En Ubuntu y Debian

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo reboot

 

En CentOS, RHEL y Fedora

sudo yum clean all
sudo yum update
sudo reboot

Fuente: Cyberciti

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *